Bluecare express tracking information conversion downtime
Incident Report for DSM Solutions
Resolved
Please contact custoer support to get the new Chrome version
Posted Mar 24, 2020 - 17:51 UTC
Investigating
We are getting reports about issues with the BlueCare service for tracking information conversion using the DSM Tool Chrome extension. We have reported the issue to the BlueCare team and we are waiting for their response, in the meanwhile the tech team of DSM Tool is looking for a workaround that will fix the problem without the need to involve BlueCare's team.
Posted Mar 07, 2020 - 07:55 UTC
This incident affected: DSM Auto Paste Chrome Extension.