Lowes wrong status and Lister issues
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 12:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 11, 2020 - 17:24 UTC
This incident affected: Rapid Lister and Bulk Lister and Price Monitor.