Chrome extention BlueCare tracking conversions
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Dec 25, 2019 - 07:12 UTC
Investigating
The issue was fixed and just waiting the new version release on google store .
Posted Nov 14, 2019 - 12:29 UTC
This incident affected: Sales & Orders.