Scanning from Amazon
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Dec 10, 2020 - 20:46 UTC
Monitoring
The scanning will be slower due to maintenance.
Maintenance time up to night
Posted Nov 30, 2020 - 08:23 UTC
This incident affected: Price Monitor.