Slow website loading reports
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 17 days ago. Jun 02, 2019 - 16:00 UTC
Investigating
We are getting reports of the website loading slow specifically the price monitor page. Our dev team has been requested to stay longer at work to fix and monitor the slowliness source and we will keep posting information about the progress.
Posted 20 days ago. May 30, 2019 - 15:55 UTC
This incident affected: Website interface and Price Monitor.