Macy's-Variations are not imported to the lister
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 12:06 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 26, 2019 - 10:52 UTC
This incident affected: Rapid Lister and Bulk Lister.