Error "Page not found" received when connecting ebay to DSM
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 09:08 UTC
Investigating
we have received complains that some user can't reconnect their DSM to ebay, our team is working to fix it
Posted 4 months ago. Jul 02, 2019 - 05:35 UTC
This incident affected: Website interface.