Browser error when logging into DSM Tool
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 14, 2019 - 18:29 UTC
Investigating
We've received reports from users about difficulties when trying to login to DSM Tool.
Tech team is working to solve this issue as we speak.
Posted 3 months ago. Feb 14, 2019 - 10:53 UTC
This incident affected: Website interface.