Upgrade is not going through
Incident Report for DSM Solutions
Resolved
BlueSnap informed that the issue on their end was resolved.
Posted 10 months ago. Oct 24, 2018 - 18:55 UTC
Identified
We've been getting reports from users that the upgrade process is not going through and not reflecting on the account.
We've confirmed with BlueSnap, the payment processor of DSM, and the issue seems to be on their side.
Please find this issue reported on their status page -
https://status.bluesnap.com/
Posted 10 months ago. Oct 24, 2018 - 07:35 UTC