Website general slowness
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 04, 2018 - 16:34 UTC
Investigating
We're experiencing a general slowness of the website interface and actions.
it's not affecting all users but we're doing out best to solve this issue ASAP!
We'll keep posting updates.
Posted 10 months ago. Nov 02, 2018 - 07:00 UTC
This incident affected: Website interface.