Sales Statistic-Week, Month & 90 days display the same value
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 09:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. Jul 16, 2019 - 18:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jul 15, 2019 - 10:38 UTC
This incident affected: Website interface.