Homedepot-Existing items with free shipping set under protection
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 18, 2019 - 10:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Jul 15, 2019 - 10:37 UTC
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jul 11, 2019 - 10:05 UTC
This incident affected: Price Monitor.