Infinite load on Sales Statistic Data in dashboard page
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 1 day ago. Jul 15, 2019 - 10:36 UTC
Investigating
We are currently investigating this issue.
Posted 5 days ago. Jul 11, 2019 - 19:14 UTC
This incident affected: Website interface.