Sent messages doesn't appear on messages history in "sales & order" page
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 09:54 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 30, 2019 - 07:41 UTC
This incident affected: Sales & Orders.