Some Homedepot items with free shipping set under protection
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 10:01 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 07, 2019 - 13:01 UTC
This incident affected: Price Monitor.