Impossible to Add note / Mark item as ordered
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 12, 2019 - 18:04 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 12, 2019 - 16:04 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Jul 12, 2019 - 16:01 UTC
This incident affected: Sales & Orders.